Catalina???

Shall I update to OS X 10.15?

09/11/19 | JT

We believe the Mac users cannot wait to test the new features of the upcoming OS X (Catalina) update. But if you want our plugins to work properly, please do NOT install OS X 10.15 yet. At this moment, our plugins are NOT 100 % compatible with Catalina. We’re working on making our software fully compatible with macOS 10.15. The update will be announced on our site.